Paxos - Crypto Transfers Incident Detected

Incident Report for Paxos

Resolved

This incident has been resolved.
Posted Aug 28, 2025 - 05:55 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 28, 2025 - 04:58 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 28, 2025 - 03:33 UTC

Investigating

We are currently experiencing delays in processing crypto deposits on our platform. Customers can still submit deposits, but processing will take longer than usual.
Posted Aug 28, 2025 - 02:46 UTC
This incident affected: Dashboard UI (Crypto Transfers), account.paxos.com UI (Crypto Transfers), and Paxos v2 API (Crypto Transfers).