Paxos - Dashboard Portal incident identified

Incident Report for Paxos

Resolved

This incident has been resolved.
Posted May 28, 2026 - 18:24 UTC

Investigating

We are currently experiencing an outage impacting email notification delivery.

As a result, the Dashboard account sign-up flow is affected, and customers may not receive emails with confirmation codes during new account onboarding, and transaction activity notifications.

Engineering is actively working to resolve the issue.
Posted May 28, 2026 - 18:08 UTC
This incident affected: Dashboard UI (Dashboard Web UI).