Paxos - USDC (Ethereum & Base) Conversions Delayed

Incident Report for Paxos

Resolved

This incident has been resolved.
Posted Aug 25, 2026 - 00:50 UTC

Update

We are continuing to monitor for any further issues.
Posted Aug 25, 2026 - 00:46 UTC

Monitoring

Processing times for USDC conversions on the Ethereum and Base networks have returned to normal. We are monitoring recovery.
Posted Aug 24, 2026 - 21:33 UTC

Investigating

We are currently experiencing delays in processing conversions involving USDC on the Ethereum and Base networks. Customers can continue to submit conversions but may experience delays in processing. Conversions involving other assets and networks are not affected.
Posted Aug 24, 2026 - 14:00 UTC
This incident affected: Dashboard UI (Stablecoin Orchestrations) and Paxos v2 API (Orchestrations API).