Paxos - USDC (Ethereum) Conversions Delayed

Incident Report for Paxos

Resolved

This incident has been resolved.
Posted Jul 17, 2026 - 22:29 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 17, 2026 - 18:34 UTC

Update

A fix has been implemented and we are monitoring the results.
Posted Jul 17, 2026 - 18:33 UTC

Investigating

We are currently experiencing delays in processing conversions involving USDC on the Ethereum network. Customers can continue to submit conversions but may experience delays in processing. Conversions involving other assets and networks are not affected.
Posted Jul 17, 2026 - 18:14 UTC
This incident affected: Dashboard UI (Stablecoin Orchestrations) and Paxos v2 API (Orchestrations API).